[WRQ Reflection へようこそ] 画面

Reflection 対話型インストールプログラムヘルプ

[WRQ Reflection へようこそ] 画面

Reflection 対話型インストールプログラムへようこそ。この画面を使用して、Reflection のイントール、Reflection の製品 CD の参照、使用可能なマニュアルの表示、WRQ Reflection の Web サイトの参照を行います。

選択するボタンによって、インストールオプションが異なります。

· Reflection のインストール: PC ワークステーションまたは共有ネットワークドライブに Reflection をインストールします。

· マニュアル: マニュアルを表示します。

· WRQ 業務内容 : WRQ の Web サイトに移動して、WRQ や WRQ の製品に関する情報を入手できます。

· インストール言語の変更: インストール言語として別の言語を選択できます。

· CD の参照: Windows エクスプローラに製品 CD フォルダのレイアウトを表示します。

関連項目


[Reflection のインストール] 画面

Reflection 対話型インストールプログラムヘルプ

[Reflection のインストール] 画面

この画面では、使用可能な製品を一覧表示してインストールしたり、製品の補足説明を表示したりします。インストールする製品を選択する場合、インストールの種類として [管理者用インストール] または [PC ワークステーション用インストール] のどちらかを選択してインストールできます。

次の手順に従ってインストールを開始します。

1 インストールする製品を選択します。

2 次のオプションのどちらかをクリックします。

· [管理者用インストール]: ネットワークまたは Web サーバ上の 1 箇所に製品の全機能をインストールします。その後、この場所から PC ワークステーション用インストールを実行できます。

· [PC ワークステーション用インストール]: 各 PC のハードディスク上に製品 (選択した機能のみ) をインストールします。

3 Reflection インストールウィザードが表示されます。各画面の指示に従って、Reflection を正しくインストールしてください。

関連項目


[マニュアル] 画面

Reflection 対話型インストールプログラムヘルプ

[マニュアル] 画面

この画面には製品マニュアルの一覧が表示されます。マニュアルは、PDF 形式になっており、Adobe Reader を使用して表示と印刷ができます。Reflection 製品の最新情報が記載された、製品の補足説明を表示することもできます。

マニュアルまたは製品の補足説明を表示するには、次の手順に従います。

1 例えば [WRQ Reflection インストールガイド] など、表示したい項目を選択します。

2 [マニュアルの表示] をクリックします。Adobe Reader が起動して、そのファイルが読み込まれます。

使用している PC に Adobe Reader がインストールされていない場合は、次の手順に従ってインストールしてください。

1 [Adobe Reader のインストール] をクリックします。

2 ブラウザに、Adobe Reader を無料でダウンロードできる Adobe ダウンロードサイトが開きます。Adobe サイトの指示に従って、正しくダウンロードしてください。

ヒント

· マニュアルまたは文書を選択すると、画面の下部にその説明が表示されます。

関連項目


[WRQ 業務内容] 画面

Reflection 対話型インストールプログラムヘルプ

[WRQ 業務内容] 画面

この画面を使用して WRQ に関する情報を表示します。[www.wrq.co.jp] をクリックすると、ブラウザに WRQ の Web サイトが表示されます。この Web ページにあるリンクを使用して、製品の詳細、サポートオプション、WRQ に関する追加情報を参照してください。

関連項目


[インストール言語の変更] 画面

Reflection 対話型インストールプログラムヘルプ

[インストール言語の変更] 画面

この画面では、表示されているプログラムで現在使用している言語を、対応している別の言語に変更します。対象言語は、英語、フランス語、ドイツ語、日本語です。

別の言語を選択すると自動的に [WRQ Reflection へようこそ] 画面に戻り、選択した言語でこの初期画面が表示されます。

関連項目


インストールの要件

Reflection のインストール

インストールの要件

このトピックでは、選択した Reflection バージョン 13.0 の機能に対応するためのシステム要件を示します。

オペレーティングシステム:

· Windows XP

· Windows Server 2003

· Windows 2000 Server または Windows 2000 Professional

Reflection 製品をインストールするための権限:

· Reflection 製品をインストールするには、管理者権限を持っているか、システム管理者に依頼してシステム特権を使用可能にしてもらう必要があります。

Web ブラウザ:

· Reflection を Web ブラウザで実行する場合、つまり、ActiveX コントロールとして Reflection を使用する場合は、Microsoft Internet Explorer 4.0 以降、Netscape Navigator 4.0 Gold 以降、または Netscape Communicator 4.0 以降が必要です。

· Reflection から XML 形式で設定をエクスポートする場合は、Microsoft Parser 3.0 と Microsoft Internet Explorer バージョン 5.0 以降、または Internet Explorer バージョン 6.0 が必要です。
注意: Internet Explorer バージョン 4.0 (Service Pack 2 以降) がマシンで検出されない場合、Microsoft の XML 機能はインストールされません。

Reflection 製品のメータリング:

· オプションのメータリング対応には、Reflection 管理者用メータリングサーバが必要です。そのサーバにレポートするように Reflection ワークステーションを設定する必要があります。[クライアントメータリングオプションの設定] ダイアログボックスを使用します。

システム管理サーバ (SMS) を使用してインストールする

· Microsoft Systems Management Server (SMS 2003 を含む) への対応情報は、Reflection で自動的に作成される Systems Management Server (.sms) ファイル形式で格納されています。これらのファイルの SMS での読み込みと実行の詳細については、カスタム設定マネージャのヘルプ (Reflection 管理者用ツールキットとともにインストールされます) や、使用している Windows インストーラのマニュアルを参照してください。

Media Application Server (MAS):

· MAS への対応には、Microsoft DirectX バージョン 8.1 以降が必要です。Microsoft DirectX バージョン 8.1 以降がマシンで検出されない場合、MAS はインストールされません。

関連項目


オンデマンドインストールへの対応

Reflection のインストール

オンデマンドインストールへの対応

オンデマンドインストールは、Microsoft Windows インストーラの機能で、Windows XP および Windows 2000 で対応しています。

オンデマンドインストールとは

Microsoft Windows インストーラ (MSI) には、製品や機能をアドバタイズするオプションがあります。つまり、特定の機能に必要なファイルは、必要になるまではハードディスクにインストールされません。通常は、アプリケーションに関連付けられたスタートメニューのショートカットまたはドキュメントで、その機能の使用が必要になった時にインストールされます。その時には、Windows インストーラサービスが必要なファイルをインストールしてアプリケーションを起動します。これは、「最初に起動した時にインストール」、「オンデマンドインストール」、あるいは Reflection では「必要な時にインストール」と呼ばれます。製品レベルと機能レベルのどちらの場合でもこのオプションを使用できます。
ヒント: カスタムインストールを実行して Reflection 機能をクリックすると、その機能が「必要な時に機能をインストールする」に対応しているかどうかをすばやく確認できます。[必要な時に機能をインストールする] 選択項目が表示された場合は、機能はこの種類のインストールに対応しています。

オンデマンドインストールオプションの使用方法

オンデマンドインストールオプションを使用して Reflection 機能をインストールする場合、次の点に注意してください。

· 管理者用インストールの場所からインストールするのが一番良い方法です。

· 一部の機能にはスタートメニュー (または他の) のショートカットがありません。例えば、Visual Basic for Applications 機能は、Reflection メニューから VBA の使用が必要なコマンドをクリックした時に Reflection 内からインストールされます。

· また、エンドユーザが [コントロールパネル] - [アプリケーションの追加と削除] を使用して、機能をインストールすることもできます (ただし、エンドユーザがこの機能を使用できる場合)。

オンデマンドインストールの代替方法

オンデマンドで使用できない機能へのアクセスをユーザに提供する必要がある場合、次の 2 つのオプションを選択できます。

· Reflection 機能に対して、別のインストールオプション ([ローカルのハードディスクにインストールする]、[ネットワークから実行するようインストールする] など) を選択します。

· 最初のインストール以降は、[コントロールパネル] - [アプリケーションの追加と削除] を使用して Reflection 製品や機能を追加します。

関連項目


Reflection 管理者用ツールキット

Reflection のインストール

Reflection 管理者用ツールキット

Reflection 管理者用ツールキットでは Reflection 管理アプリケーションとユーティリティが使用できます。この管理者用ツールキットは、単体のインストールで、管理コンポーネントを Reflection 製品フォルダとは別のフォルダにインストールします。

これらの管理コンポーネントは、既定で C:¥Program Files¥WRQ¥Rtoolkit にインストールされ、次のものが含まれます。

· Reflection カスタム設定マネージャ

· すべての Reflection プロファイラ

· 管理テンプレートファイル形式のグループポリシー対応機能

· 管理アプリケーションが必要とする *.dll と初期化ファイル

Reflection 管理者用ツールキットをインストールするには、次の手順に従います。

1 PC の CD-ROM ドライブに Reflection の製品 CD を挿入します。ほとんどのシステムでは、インストールプログラム (Install.exe) が自動的に起動します。

2 [Reflection のインストール] をクリックします。

3 [Reflection のインストール] パネルで、[Reflection 管理者用ツールキット] をクリックしてから [PC ワークステーション用インストール] をクリックします。

4 インストールが開始されます。インストールフォルダを指定するよう指示された場合、現在の Reflection フォルダを選択しないでください (これは要件です)。代わりに、既定値を使用するか、別のローカルフォルダを選択してください。

管理者用ツールキットコンポーネントのインストール後は、Windows の [スタート] - [プログラム] から [WRQ Reflection]、[管理ツール] フォルダの順に選択して、各種ユーティリティにアクセスできます。このフォルダには、Reflection プロファイラとカスタム設定マネージャが入っています。グループポリシー対応機能の場合には、ポリシーエディタを開いて、¥Inf フォルダから管理ファイルを選択します。詳細については、Reflection 製品のオンラインヘルプを参照してください。


Reflection カスタム設定マネージャ

Reflection のインストール

Reflection カスタム設定マネージャの概要

カスタム設定マネージャは、システム管理者が Reflection の準備、カスタム設定、配布をできるだけ簡単に行えるようにするための強力なユーティリティです。このユーティリティを使用して、Reflection ユーザに製品を配布する前にファイルサーバまたは Web サーバ上にインストールを準備したり、Reflection をカスタム設定します。カスタム設定マネージャでは、Reflection 製品インストールパッケージファイルとともに機能して、カスタム設定したバージョンの Reflection をインストールする、Windows インストーラと互換性のあるトランスフォームを作成できます。Active Directory や SMS などのインストーラと互換性のある配布用ツールを使用して、製品を配布します。または、カスタム設定マネージャで Windows ショートカットまたはリンクを含む Web ページを作成し、エンドユーザが使用できるようにします。エンドユーザがそれをクリックすると、製品がワークステーションにインストールされるようにします。

カスタム設定マネージャは、「Reflection 管理者用ツールキット」のヘルプトピックの手順に従ってインストールできます (リンクをクリックすると、この手順が表示されます)。

関連項目


「Reflection インストールガイド」の表示と印刷

Reflection のインストール

「Reflection インストールガイド」の表示と印刷

WRQ の「Reflection インストールガイド」には、印刷版と PDF 版があります。PDF 版は製品 CD に収録されています。また、Web ページ support.wrq.com/manuals/ にアクセスして PDF (Portable Document Format) 版の WRQ 製品マニュアルをダウンロードすることもできます。インストールガイドには英語、フランス語、ドイツ語、日本語版がありますが、その他のマニュアルはほとんどが英語版です。

このガイドの表示や印刷を行う場合は、次の手順に従って Adobe Reader でガイドを開きます。

1 PC の CD-ROM ドライブに Reflection の製品 CD を挿入します。ほとんどのシステムでは、インストールプログラム (Install.exe) が自動的に起動します。

2 [マニュアル] を選択し、表示されたパネルで [WRQ Reflection インストールガイド] を選択します。

3 [マニュアルの表示] をクリックして、Adobe Reader でマニュアルを開きます。

注意: コンピュータに Adobe Reader がインストールされていない場合は、[Adobe Reader のインストール] をクリックして Adobe のサイトにアクセスし、この無料の表示用アプリケーションの最新版をダウンロードしてください。


管理者特権の必要性

Reflection のインストール: インストールの問題の対策

管理者特権の必要性

Windows XP、Windows Server 2003、Windows 2000 Server または Workstation でのインストールに必要な権限

これらのオペレーティングシステムに、Reflection をインストールする管理権限を持っているか、Reflection 製品をインストールできるシステム特権をシステム管理者に依頼して使用可能にしてもらう必要があります。

関連項目


WRQ への連絡先

WRQ のヘルプ

WRQ への連絡先

WRQ では皆様に質の高い技術サポートの提供を心がけております。情報システムを円滑に運営させることが企業の成功につながり、ご使用になるソフトウェアはその重要な要素となります。WRQ では、企業の生産性を高め、またコストを最小限におさえるためのお手伝いをいたします。

一般的なお問い合わせ

WRQ に関する一般的なお問い合わせや Reflection 製品の購入に関するお問い合わせに関しては、http://www.wrq.com/aboutwrq/contact にアクセスして、ご希望の連絡先をクリックしてください。

サポート Web サイト上のヘルプ

WRQ Reflection 製品に関する質問がある場合は、Web サイト http://support.wrq.com で技術サポートの情報を得ることができます。 ただし、このサイトは英語で表記されていますことをご了承ください。

米国およびカナダ国内での技術サポート

米国またはカナダ国内で製品のサービスプランをご購入された場合は、WRQ の技術サポートチームから直接サポートを受けることができます。+1.206.217.7000 までご連絡いただくか、あるいは Web サイトでサポート要請を提出してください。

Web サイトでは、WRQ のサポートプログラムに関する情報も掲載されています。所属する会社が Premium Support の資格を有しているかどうかわからない場合は、WRQ の正規代理店または WRQ の販売部門 (800.872.2829) にお問い合わせください。

日本国内での技術サポート

米国外での技術サポートについては、support.wrq.com で該当するサポートリンクをクリックしてください。

技術マニュアル

Web ページ support.wrq.com/manuals/ にアクセスして PDF (Portable Document Format) 版の WRQ 製品マニュアルをダウンロードできます。ただし、ほとんどが英語版です。

WRQ 社の Web サイト

WRQ 社と製品に関する詳しい情報は、www.wrq.co.jp をご利用ください。

カスタマーサービス

WRQ の製品に関するご質問は、以下の連絡先にお問い合わせください。

本社

1500 Dexter Avenue North

Seattle, WA 98109 USA

+1.206.217.7100

800.872.2829

ヨーロッパ支社

オランダ

+31.71.368.11.11

+31.71.368.11.81 FAX

アジア・太平洋支社

シンガポール

+65.6336.3122

+65.6336.5233 FAX


[管理者用インストール]

[管理者用インストール] オプションは、ファイルサーバとネットワーク接続されているコンピュータ用に、Reflection をファイルサーバ上に配置するために使用します。エンドユーザは、[管理者用インストール] を使用して Reflection をローカルコンピュータにインストールできます。カスタム設定マネージャを使用してトランスフォームファイルを作成し、エンドユーザのインストールをカスタム設定できます。これを行うには、管理者のコンピュータに対して WRQ Reflection [管理者用ツールキット] の [管理者用インストール] を実行してから、そのコンピュータでカスタム設定マネージャを実行してください。


機能とは

機能

機能とはインストール可能な製品またはコンポーネントであり、通常はその下にサブ機能があります。サブ機能は、機能ボックスの横にある X 印をクリックすると表示できます。


インストール方式

インストール方式により、機能全体がハードディスク (ローカルのハードディスク) とファイルサーバ (ネットワークからの実行) のどちらにインストールされるかを決定します。


Windows インストーラ

Microsoft Windows インストーラは、Windows XP と Windows 2000 に付属するインストールプログラムです。このインストールプログラムにより、機能とインストールの既定オプションを選択できます。


PDF (Portable Document Format) ファイル

PDF ファイル

電子ファイルである PDF マニュアルには、印刷マニュアルと同じ情報が記載されています。PDF マニュアルには、印刷マニュアルに付随する問題、つまり分厚くてかさばるといったことや環境資源の問題がないという利点があります。Adobe Reader を使用して、PDF マニュアルを表示および印刷できます。詳細については、ここをクリックしてください。


[PC ワークステーション用インストール]

[PC ワークステーション用インストール] オプションは、1 台のコンピュータに Reflection を単体でインストールする場合、または、システム管理者が、[管理者用インストール] オプションを指定してインストールしたサーバ用の Reflection を構成するために、Reflection の機能と管理者用ツールキットをローカルで使用する場合に指定します。

ネットワーク上の管理者用インストールから PC ワークステーションに Reflection をインストールする

PC ワークステーション用インストールは、共有ネットワークリソースから製品を実行する「ネットワークから実行するようインストールする」とは異なります。「ネットワークから実行するようインストールする」では、管理者用インストールから製品を直接インストールし、ローカル PC で Reflection を実行します。この場合、Reflection の実行に必要な最小限のファイルとレジストリ設定がローカル PC にインストールされます。


Systems Management Server を使用した Reflection のインストール

Reflection のインストール

Systems Management Server を使用した Reflection のインストール

このトピックでは、Microsoft Windows で動作するコンピュータに、Microsoft の Systems Management Server (SMS) を使用して Reflection 製品を 配布する方法について説明します。この説明は Microsoft の SMS の操作に詳しいシステム管理者を対象としています。SMS の使用方法の詳細については、「Microsoft Systems Management Server 管理者ガイド」を参照してください。

Microsoft Windows インストーラの必要なバージョン

このヘルプトピックでは、使用するコンピュータに Microsoft Windows インストーラソフトウェアがすでにインストールされていることを前提にしています。このサービスがインストールされていない場合、または Reflection のインストール先のコンピュータがバージョン 2.0 以前のものを使用している場合、SMS を使用して Reflection を配布する前に、これらのコンピュータをアップデートする必要があります。
注意: Microsoft Windows インストーラサービスのバージョン 3.0 は Reflection 製品 CD の ¥Reflection¥MSI フォルダに収録されています。

SMS を使用した Reflection のインストール

SMS を使用して Reflection をインストールするには、次の手順に従います。Reflection のインストール先の各コンピュータで、MSI サービスがバージョン 2.0 以降にアップデートされていることを確認してください。また、SMS を使用して製品をインストールする前に Reflection をカスタム設定する場合は、カスタム設定マネージャを使用して行ってください。SMS の操作方法の詳細については、Microsoft 製品のマニュアルを参照してください。

Systems Management Server を使用して Reflection をインストールするには、

1 SMS サイトサーバーに対して管理者用インストールを実行します。これが、配布を実行する管理者用インストールの場所になります。

注意: 製品定義ファイル (.sms) は、管理者用インストールの実行中に、管理者用インストールの場所のルートフォルダに作成されます。例えば、Reflection Suite for X の管理者用インストールを作成している場合、Sx130ilc.sms ファイルがルートフォルダに作成されます。または、msi ファイルを直接参照することもできます。詳細については、SMS のマニュアルを参照してください。Reflection は SMS バージョン 1.2 に対応していません。

2 Reflection カスタム設定マネージャを使用して、Reflection インストールパッケージ (*.msi) をカスタム設定することもできます。このユーティリティを使用すると、カスタム設定を含むトランスフォームファイル (*.mst) が生成されます。

3 Reflection 製品定義ファイル (sms) を使用して、Reflection インストールパッケージを作成します。カスタム設定マネージャユーティリティを使用して Windows インストーラトランスフォーム (.mst) ファイルを作成した場合、[プロパティ] タブで コマンドラインを編集して、SMS 内の Reflection インストールパッケージのプログラムにファイルを追加します。例えば、[標準] インストールプログラムの [プロパティ] タブで、shipdept.mst というトランスフォームを使用する Reflection Suite for X のコマンドラインは次のようになります。

"msiexec /i sx130ilc.msi TRANSFORMS="shipdept.mst"

4 インストールパッケージをユーザにアドバタイズします。繰り返しますが、Reflection のインストールの前に必ず、MSI サービス 2.0 以降を配布してください。

関連項目